poj2299

链接:poj2299

Description

  • In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n
  • distinct
  • integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the
  • input sequence
  • 9 1 0 5 4 ,
  • Ultra-QuickSort produces the output
  • 0 1 4 5 9 .
  • Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given
  • input sequence.

    Input

  • The input contains several test cases. Every test case begins with a line that contains a single integer n <
  • 500,000 — the
  • length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,
  • 999, the i-th
  • input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

    Output

  • For every input sequence, your program prints a single line containing an integer number op, the minimum
  • number of swap
  • operations necessary to sort the given input sequence.

    Sample Input

    5
    9
    1
    0
    5
    4
    3
    1
    2
    3
    0

    Sample Output

    6
    0

    题解

  • 求逆序对数目
  • 开一个大小为这些数的最大值的树状数组,并全部置0。从头到尾读入这些数,每读入一个数就更新树状数组,查看它前面比它小的已出现
  • 过的有多少个数
  • sum,然后用当前位置减去该sum,就可以得到当前数导致的逆序对数了。把所有的加起来就是总的逆序对数。
  • 然而问题来了,数据最大999999999,显然开不下
  • 解决方法是离散化一下
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
#include<iostream>
#include<algorithm>
#include<cstring>
#define lowbit(i) i&(-i)
#define rep(i,x,y) for(register int i=x;i<=y;++i)
#define repd(i,x,y) for(register int i=x;i>=y;--i)
#define ll long long
using namespace std;
const int N=5e6+100;
struct node{
int val,pos;
}b[N];
int a[N],tree[N],n;
ll ans;

bool cmp(node x,node y){
return x.val<y.val;
}

void add(int x,int k){
for(int i=x;i<=n;i+=lowbit(i))tree[i]+=k;
}

int getsum(int x)
{
int ans=0;
for(int i=x;i>0;i-=lowbit(i))ans+=tree[i];
return ans;
}

void readin(){
rep(i,1,n){
cin>>b[i].val;
b[i].pos=i;
}
memset(a,0,sizeof(a));
memset(tree,0,sizeof(tree));
sort(b+1,b+n+1,cmp);
rep(i,1,n){
add(b[i].pos,1); //离散化
ans+=i-getsum(b[i].pos);
}
}

int main(){
ios::sync_with_stdio(false);
while(cin>>n){
if(n==0)break;
ans=0;
readin();
cout<<ans<<endl;
}
return 0;
}