hdu5627

链接:hdu5627

Description

  • Clarke is a patient with multiple personality disorder. One day he turned into a learner of graph theory.
  • He learned some algorithms of minimum spanning tree. Then he had a good idea, he wanted to find the maximum
  • spanning tree with bit operation AND.
  • A spanning tree is composed by n−1 edges. Each two points of n
  • points can reach each other. The size of a spanning tree is generated by bit operation AND with values of
  • n−1 edges.
  • Now he wants to figure out the maximum spanning tree.

    Input

  • The first line contains an integer T(1≤T≤5), the number of test cases. For each test case, the first line
  • contains two integers n,m(2≤n≤300000,1≤m≤300000), denoting the number of points and the number of edge 、
  • respectively. Then mlines followed, each line contains three integers x,y,w(1≤x,y≤n,0≤w≤109), denoting an 、
  • edge between x,ywith value w.
  • The number of test case with n,m>100000 will not exceed 1.

    Output

  • For each test case, print a line contained an integer represented the answer. If there is no any spanning
  • tree, print 0.

    Sample Input

    1
    4 5
    1 2 5
    1 3 3
    1 4 2
    2 3 1
    3 4 7

    Sample Output

    1

    题解

  • 按位与最大生成树,从最高位贪心到最低位,看该位和其他已经获得的位能否构成生成树
  • 能构成就加上这一位,不然就扔掉
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
#define rep(i,x,y) for(register int i=x;i<=y;++i)
#define repd(i,x,y) for(register int i=x;i>=y;--i)
using namespace std;
const int N=1e6;
int x[N],y[N],w[N],f[N];

int find(int x){
return f[x]==x?x:f[x]=find(f[x]);
}

int un(int x,int y){
x=find(x);y=find(y);
if(x!=y){
f[x]=y;
return 1;
}
return 0;
}
int main(){
int t,n,m;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
rep(i,1,m)scanf("%d%d%d",&x[i],&y[i],&w[i]);
int ans=0;
repd(i,20,0){
ans+=(1<<i);
rep(j,1,m)f[j]=j;
int cnt=0;
rep(j,1,m)if((w[j]&ans)==ans&&un(x[j],y[j]))cnt++; //注意此处不是(w[j]&(1<<i))==(1<<i)
if(cnt!=n-1)ans-=(1<<i);
}
printf("%d\n",ans);
}
return 0;
}