hdu1233

链接:hdu1233

Description

  • 某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路
  • 交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

    Input

  • 测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正
  • 整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
  • 当N为0时,输入结束,该用例不被处理。

    Output

  • 对每个测试用例,在1行里输出最小的公路总长度。

    Sample Input

    3
    1 2 1
    1 3 2
    2 3 4
    4
    1 2 1
    1 3 4
    1 4 1
    2 3 3
    2 4 2
    3 4 5
    0

    Sample Output

    3
    5

    题解

  • 模板题
  • 写的kruskal
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
#define rep(i,x,y) for(register int i=x;i<=y;++i)
#define repd(i,x,y) for(register int i=x;i>=y;--i)
#define abs(x) x=x>0?x:(-x)
#define ll long long
using namespace std;
const int N=1e5;
struct node{
int u,v,w;
bool operator <(const node y){return w<y.w;}
inline void init(int a,int b,int c){u=a; v=b; w=c;}
}e[N];
int f[N],n,m;

template <typename T>inline void read(T &x){
char c;int sign=1;x=0;
do{c=getchar(); if(c=='-')sign=-1;}while(c<'0'||c>'9');
do{x=x*10+c-'0';c=getchar();}while(c>='0'&&c<='9');
x*=sign;
}
int find(int x){return f[x]==x?x:f[x]=find(f[x]);}
int un(int x,int y){x=find(x); y=find(y); return x==y?0:f[x]=y;}
int kruskal(){
rep(i,1,n)f[i]=i;
int ans=0,cnt=0;
rep(i,1,m){
int x=find(e[i].u);
int y=find(e[i].v);
if(un(x,y))ans+=e[i].w,cnt++;
if(cnt==n-1)return ans;
}
}


int main(){
while(~scanf("%d",&n)&&n){
m=n*(n-1)/2;
rep(i,1,m){
int a,b,c;
read(a);read(b);read(c);
e[i].init(a,b,c);
e[m+i].init(b,a,c);
}
m<<=1;
sort(e+1,e+m+1);
printf("%d\n",kruskal());
}
return 0;
}